advertisement

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Medtronic Quick-sets

Discussion in 'Insulin Pumps' started by HopesDaddy, Mar 11, 2012.

  1. HopesDaddy

    HopesDaddy Approved members

    Joined:
    Mar 8, 2012
    Messages:
    5
    We have had issues with Quick-sets getting stuck in the inserter. Our fix has been to trim the edge so that they don't hang up or jam the inserter part way in. Has Medtronic fixed this, or are we the only ones having this problem?
    Thanks for your insight!
     
  2. jules12

    jules12 Approved members

    Joined:
    May 26, 2007
    Messages:
    2,330
    Sounds like you might have a different problem. However, when we were using quicksets, we had them get stuck or the adhesive would stick to the sides sometimes. What solved it was to clean around the inside of the serter where there was some adhesive buildup. I just took an alcohol wipe and cleaned it and didn't have any more issues.

    Also, could be your serter is old....
     
  3. Kaylas mom

    Kaylas mom Approved members

    Joined:
    Apr 14, 2010
    Messages:
    1,306
    We have had the adhesive get stuck too, I don't think it is an issue with the serter just that we let go of the set and it jiggled enough to stick to the side while trying to put it up against the skin.
     
  4. jilmarie

    jilmarie Approved members

    Joined:
    Jan 29, 2007
    Messages:
    773
    Yep, take an alcohol prep and give the inside of the quick-serter a good cleaning. My sets used to stick and cleaning the inserter solved the problem. Hope that works!
     
  5. Connie(BC)Type 1

    Connie(BC)Type 1 Approved members

    Joined:
    Nov 11, 2005
    Messages:
    3,388
    Call medtronic, I've had to have 6+ lots replaced, and don't take no for an answer! They know it's an issue with the sets being too large for the serters. The USA customer service is great, the Canadian side you need the male rep, he's wonderful, his name is Brad
     
  6. HopesDaddy

    HopesDaddy Approved members

    Joined:
    Mar 8, 2012
    Messages:
    5
    We have cleaned the serter with alcohol till it shines with no difference. Medtronic has replaced several lots of quick-sets for us, but the problem is still here. I asked them to take a few thousandths off the sets, as it seems like tooling that is slightly worn, making a larger cut. I guess we wil keep the scissors handy until we get another new serter.
    Thanks for everybody's input!
     
  7. mylemonadelife

    mylemonadelife Approved members

    Joined:
    Jan 3, 2012
    Messages:
    32
    I have had this issue as well. I usually pinch the tape up like a taco for a few seconds then it doesn't touch or stick to the sides anymore.
     
  8. jules12

    jules12 Approved members

    Joined:
    May 26, 2007
    Messages:
    2,330
    Definitely sounds like you have a bigger issue than adhesive sticking. Have you tried the mios? We have switched over to them from the quicksets. Might want to try some if you haven't.
     
  9. Connie(BC)Type 1

    Connie(BC)Type 1 Approved members

    Joined:
    Nov 11, 2005
    Messages:
    3,388
    I'm pretty sure it's not the serter, but they sent me 2 new ones anyhow, before they started replacing boxes. Ask for a new serter, and KEEP complaining until they fix the problem for you. I haven't opened my new lots yet, so my fingers are crossed that they'll work
     

Share This Page

advertisement