advertisement
Results 1 to 9 of 9

Thread: Medtronic Quick-sets

  1. #1
    Join Date
    Mar 2012
    Location
    Near Bakersfield CA
    Posts
    5

    Default Medtronic Quick-sets

    We have had issues with Quick-sets getting stuck in the inserter. Our fix has been to trim the edge so that they don't hang up or jam the inserter part way in. Has Medtronic fixed this, or are we the only ones having this problem?
    Thanks for your insight!
    HopesDaddy
    Hope age 8 dxd 3-3-08 MM 522 Nov. 08

  2. #2
    Join Date
    May 2007
    Location
    Midwest
    Posts
    2,326

    Default

    Sounds like you might have a different problem. However, when we were using quicksets, we had them get stuck or the adhesive would stick to the sides sometimes. What solved it was to clean around the inside of the serter where there was some adhesive buildup. I just took an alcohol wipe and cleaned it and didn't have any more issues.

    Also, could be your serter is old....
    Son dx 2007, Pumping 2007
    Cgms 2008 Minimed Revel Pump 2010
    6mm Mios

  3. #3

    Default

    We have had the adhesive get stuck too, I don't think it is an issue with the serter just that we let go of the set and it jiggled enough to stick to the side while trying to put it up against the skin.

    Amy~ mom to
    Kayla~18 T1 dx 4/24/10 pumping with purple revel 12/22/10
    Noah~15 T1 dx 1/31/11
    and Nick~11, primary immune def (CVID) receives IVIG, asthma

  4. #4

    Default

    Yep, take an alcohol prep and give the inside of the quick-serter a good cleaning. My sets used to stick and cleaning the inserter solved the problem. Hope that works!
    Jill - adult type 1.
    Minimed pump, Dexcom.

  5. #5
    Join Date
    Nov 2005
    Location
    British Columbia
    Posts
    3,385

    Default

    Call medtronic, I've had to have 6+ lots replaced, and don't take no for an answer! They know it's an issue with the sets being too large for the serters. The USA customer service is great, the Canadian side you need the male rep, he's wonderful, his name is Brad
    My 1st meter from the 70's

  6. #6
    Join Date
    Mar 2012
    Location
    Near Bakersfield CA
    Posts
    5

    Default

    We have cleaned the serter with alcohol till it shines with no difference. Medtronic has replaced several lots of quick-sets for us, but the problem is still here. I asked them to take a few thousandths off the sets, as it seems like tooling that is slightly worn, making a larger cut. I guess we wil keep the scissors handy until we get another new serter.
    Thanks for everybody's input!
    HopesDaddy
    Hope age 8 dxd 3-3-08 MM 522 Nov. 08

  7. #7

    Default

    I have had this issue as well. I usually pinch the tape up like a taco for a few seconds then it doesn't touch or stick to the sides anymore.
    ~Rae~
    Previous username: s0ccerfreak
    21, dx'd 3/1998
    Pumping untethered: MM 722 and Lantus
    CGMS 11/2007
    "Don't tell God how big your mountains are, tell your mountains how big your God is."

  8. #8
    Join Date
    May 2007
    Location
    Midwest
    Posts
    2,326

    Default

    Quote Originally Posted by HopesDaddy View Post
    We have cleaned the serter with alcohol till it shines with no difference. Medtronic has replaced several lots of quick-sets for us, but the problem is still here. I asked them to take a few thousandths off the sets, as it seems like tooling that is slightly worn, making a larger cut. I guess we wil keep the scissors handy until we get another new serter.
    Thanks for everybody's input!
    Definitely sounds like you have a bigger issue than adhesive sticking. Have you tried the mios? We have switched over to them from the quicksets. Might want to try some if you haven't.
    Son dx 2007, Pumping 2007
    Cgms 2008 Minimed Revel Pump 2010
    6mm Mios

  9. #9
    Join Date
    Nov 2005
    Location
    British Columbia
    Posts
    3,385

    Default

    Quote Originally Posted by HopesDaddy View Post
    We have cleaned the serter with alcohol till it shines with no difference. Medtronic has replaced several lots of quick-sets for us, but the problem is still here. I asked them to take a few thousandths off the sets, as it seems like tooling that is slightly worn, making a larger cut. I guess we wil keep the scissors handy until we get another new serter.
    Thanks for everybody's input!
    I'm pretty sure it's not the serter, but they sent me 2 new ones anyhow, before they started replacing boxes. Ask for a new serter, and KEEP complaining until they fix the problem for you. I haven't opened my new lots yet, so my fingers are crossed that they'll work
    My 1st meter from the 70's

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •